Browse Source

ci: run matrix build with go 1.7.x - 1.x

The .travis.yml file has been updated so that CI will also attempt to
build the kernel using the latest go branches from 1.7, 1.8, 1.9, 1.10,
1.x.

The tests will only be run once against the latest go version.
pull/66/head
Achilleas Anagnostopoulos 1 year ago
parent
commit
bb81bb3550
1 changed files with 25 additions and 5 deletions
  1. 25
    5
      .travis.yml

+ 25
- 5
.travis.yml View File

@@ -1,9 +1,29 @@
language: go
sudo: required
addons:
apt:
packages:
- nasm
- binutils-2.26
# Compile kernel with various go versions
go:
- 1.7.x
- 1.8.x
- 1.9.x
- 1.10.x
- 1.x
script:
- make lint
- make collect-coverage
after_success:
- bash <(curl -s https://codecov.io/bash)
stage: build kernel
before_install:
- export PATH=/usr/lib/binutils-2.26/bin:${PATH}
script: make kernel

# Run the tests against the latest go version
jobs:
include:
- stage: run tests
go: 1.x
script:
- make lint
- make collect-coverage
after_success:
- bash <(curl -s https://codecov.io/bash)

Loading…
Cancel
Save